Shopbot Usb drive

Cannot get usb drive to open on Shopbot PC. I feel like I’m missing something simple Cannot find drive in menus. Tried 2 drives with g-code and multiple members helping. Most people think on that PC the drive normally
opens automatically when inserted. Is this true or is there something to “click on”?

That Linux distribution is odd and makes it hard to figure out how to open a file view. I don’t remember how to do it to describe here but could meet you there and I’m sure we can figure it out. I could be there tonight around 6pm or we could arrange some other time as well. Let me know.

6pm works for me. Thanks so much Dave

Sounds good. See you then.

Im coming had to work late!

We got it figured out. I’m posting 3 ways to get to the thumb drive so I know how next time I forget.
NOTE: One of the USB ports on the front of the computer may be non-functional; try another port if these steps don’t work.

Option 1 - From within LinuxCNC

  • Click the Folder icon
  • Click on Directory and slide up to ‘/’ (this is called ‘root’ in Linux)
    – Select ‘media’
    – Select your thumb drive

Option 2 - From ‘K’ icon (lower left corner of screen)

  • Click ‘K’
  • Click ‘Computer’
    – Click ‘root’
    – Click ‘Media’
    – Select your thumb drive

Option 3 - From ‘K’ icon (lower left corner of screen)

  • Click ‘K’
  • Click ‘Computer’
  • Scroll to the bottom of the list to see the ‘Removable Storage’ section
    – Select your thumb drive

Very helpful thanks so much!

I was able to get in yesterday, but now i am having the same problem. Tried all methods above and tried all usb slots. Anyone have any idea?

Well i think the shop bot linux computer may have corrupted my drive. I think one of the usbs on the front of the computer are bad.

I’ve heard that mentioned a couple times. Someone should figure out which one and tape it off.

1 Like

I used the open one on the back yesterday without issues.