Cnc plasma cutter Status

I hooked the computer back up, and tested all of the limit switches. I did not bring my consumables, so I was not able to test cutting. It moves and I have no reason to believe it will not work. Have at it and report back any issues. New or Old.

It is missing the splash guard. I was going to clean up the surface and reattach it. I seem to have misplaced it, or someone threw it away because it looked like a dirty piece of plastic.

I will try to come down an evening this week and do some test cuts myself. I was removing the nozzle and the torch was spinning in the mount. Make sure to hold the upper port of the torch when swapping the consumables. I don’t think it should cause an problems, unless it becomes too loose.

I will go back to working on an aluminum magnetic mount.

6 Likes

I tried to do a test cut Thursday Nov 7 on the plasma cutter, but there is a problem with sheetcam. It will hangs while launching the application. It is on the todo list to fix. I did not have the time to generate the gcode from fusion.

I have prototype no. 2 of the magnetic mount.

I have taken the time to remove the zip ties. They are replaced with a hard cover. It will be screwed down, so it should resolve the rotation issue the zip ties had.


To address the side to side movement. I have seen it impact cuts a noticeable amount in the X axis. I have added four adjustment points to remove the lateral play. There are pockets that I have embedded 3/16 ball bearings that are backed up with screws. Each bearing can be adjusted 3-4 mm. This will allow it to fit snugly to the steel plate. The bearings should be allowed to rotate to still allow the torch mount to move upwards if the tip contacts the metal being cut.

My plan is to CA glue to fix the magnets or double sided tape in the holes.


3 Likes

Good news and bad news.
The high leg has been lowered, so in theory the table is level.

Version two of the mount is working better in some ways, not as good in others. The many smaller magnets do keep it attached, but it pops off too easy for my tastes. The adjustment do provide fine adjustment side ti side but are too shallow, so they act as a wedge and pull the magnets away from the metal plate too easy. I went with the fall back plan, and added some double stick tape to keep it attached. It should work for a few days until I can get back to it.

I have larger magnets, but they seem too large, but it is hard to tell without trying it out on the real thing. The torch is quite long, and is a very good lever, so it easy to pull it off if you try

As I had the torch upside down, and I was staring down the barrel. I saw that there was a buildup of stuff at the top of the black section meets the main gray body of the torch. I cleaned it out, and you can see the screws again. After clearing it out there are vent holes. I don’t know if they are for drawing in outside air, or exhaust holes.

I did a test cut. I found the smallest example file on the drive. Sheetcam is still not launching. I plan to reinstall to try to fix it. I will try to reinstall it an evening this week. If not it will have to wait until next weekend.

For now you will need to use fusion 360 ( on the wiki http://makeict.org/wiki/CNCPlasmaCutter#Fusion_360). It is not the easiest way to do it, but it did generate a file. I forgot my flash drive at home so I was not able to test it.

The Bad news of the day
When I was on the floor trying to see why the leveling nut on the table let would not turn any further I found there is a tiny leak in the pan. Not a ton, just two drops hanging from the bottom of the pan on the seam, and small spot on the ground.

If anyone has a magical ideas how to track down a tiny hole in a 48" long soldered and riveted seam let me know. I thought about taping a tube on the underside along the seam and apply compressed air in to look for bubbles on the topside.

I was planning to drain and swap the water in the pan anyway. Until I get better feedback about what to put in the table it would be better to run plain tap water then a low concentration of the rust inhibitor and what it breaks down into.

Thank you Tom R for coming down, and helping me out today.

1 Like

While examining the flex of the gantry and noise of the plasma cutter I saw grease fittings on the shuttles of the rails. I have wiped off red bearing grease from the rails. I assume someone applied it to the outside but it might have squeezed out.

Has anyone greased these in the recent past please let me know. It would save me the trouble of doing it again.

1 Like

The smaller piece was cut on Sunday, and the circle was cut tonight during maker Monday. It is the best case part to cut, it is to the upper range for the 45A setting, so it was a slow cut. It has no corners so there are zero movement artifacts. Just a small dimple at the lead in. I am 99% happy with the cut. See images below.

I will wait to cut my second part once sheetcam is working.

I received the original license for sheetcam from the member that purchased it originally, so I think I have all I need to reinstall the full version. I am installing a vm copy of linuxcnc at home to try and reproduce the issue from backed up files a bit tonight.

If there is anyone with sheetcam configuration experience please let me know. If you are someone with general computer skills that would be willing to try to pull the configs from sheetcam folder, and apply them to the demo sheetcam install to see if it breaks, now is your chane.

I fall into the second group. Never configured sheetcam. I was in charge of getting linuxcnc talking to the torch height controller.


image

image
image
image

2 Likes

I can give it a shot. Is it the sheetcam on the plasma cutter pc?

1 Like

Yes, everthing should be under the /home/plasma/. There are a couple sub folders. i was going to compare against the fress install to see what I need to pull from the existing computer.

2 Likes

I can reproduce the issue with a fresh install of the very old linuxcnc installer, so this leads me to be believe it is a configuration problem.

Sorry @Dje4321, I t bugged me last night so I kept working on it. I tried to selectively remove things (plugins, old references to project files, ect) from the ini file to see what might let it load. That became too much of a hack so I game up last night and went to bed.

Removing the ini file allows the software to boot. At lest on my home linuxcnc vm.

If nobody with past knowledge of configuring sheetcam steps forward to help out. I will reconfigure the software from a fresh copy. (move the current ini file out of the way) .

Then start re configuring the software from zero. To match out table/setup. We should have the tools, and the post processor, so it should not be too bad. Just something I have not done before, so please wait a little while longer. I should be able to test it all configs from home, but I will not be down to do any test cuts until next weekend.

I got it working :smiley:

there were a few things that were messed up with the config but not a whole lot. Layout, autodebug, a few parameters outside of the main config but its good to go now. Feel free to diff the files to see what exactly changed

Might need to reinstall the license though but i have no clue. Dont even know how to use sheetcam all that much :woman_shrugging:

EDIT: Thanks @sdowens helping me fumble my way through sheetcamtng

1 Like

Thanks a lot.

I don’t think I will be down to the space until this weekend to do any test cuts. If you get a chance can you post the modified ini file? I can compare them and run some tests at home in the evenings.

If not I can try to drop in Friday night after work. If the license was reset I can reinstall it this weekend.

2 Likes

Fixed Version
https://hastebin.com/bilifimaxa.makefile

Old Version
https://hastebin.com/paqumuvadi.makefile

1 Like

Thank you Emily. It does look like a functioning sheetcam version.

It looks like it is producing code from the backup, and the altered ini file (@Dje4321 thanks). It seems the same as I remember it.

Since I don’t know who or what caused the issue before Please be careful of any files produced, and make sure to review them in linuxcnc before cutting, and keep the e-stop handy.

2 Likes