Cnc plasma down/unreliable

use the cnc plasma at your own wallets risk!

we are having an issue with the limit switches randomly tripping again, one of the brackets holding the torch broke (plan on making a new one with the tormach next week), and the z axis has been behaving strangely…not sure if it is loosing steps or something is loose.

either way it cuts unreliable so again…use at your own wallets risk

prob needs a good blowout of the control boards and some cleaning. Will try to fix it next Tuesday.


1 Like

Thanks for the update I’ll try to be around Tuesday with pizza or elbow grease.

Thanks for the heads up. What time were you thinking on Tuesday? I’m not sure if I’ll be free while there’s daylight out but I’d like to help however I can.

Hey, found this topic and figured it was best to hijack it rather than start a whole new thread.
I was using the PlasmaCNC last week (Wed and Thu) because I hadn’t seen this thread, and it worked fine after tightening some of the connections on the limit switches.

Yesterday I came in and tried to use it again, but ran into a problem. I set it all up, and did a dry run without the torch on and it all worked fine. But when I turned the torch on, the torch has fault 0-51. (See photo). The manual indicates this happens when the trigger on the torch is pulled when the machine is powered on, solution is to release the trigger and power cycle the Hypertherm.

I did some tracking down and debugging since the Torch-On signal is coming from the plasma CNC. It seems that the LinuxCNC PC has no effect, the Hypertherm has a fault on power on whether the PC is on or off, and also whether the LinuxCNC software is loaded or unloaded.

The Hypertherm will power on with no fault IF the PlasmaCNC table is powered off. So there is some signal for Torch-On. I tracked the cable for controlling the Hypertherm backwards through the THC, onto the PlasmaCNC table and down to this relay module.

The red and black wires on the right are ARC-START and ARC-STOP,
the red and black on the left are 5V, GND, and the white is PIN14 from the plasmaCNC table. There is a little light up on the top left that I believe is indicating the relay state, and the relay does not seem to switch at all during the dry run of a part.

I haven’t had time to dig further and look up documentation for the relay module or the controller, but it would seem that either there is a bad signal coming from the controller, or the relay is stuck.

I’m going to power off the LinuxCNC PC, blow it off, blow off the boards on the back of the table, and see if that helps, but for now the table seems completely down.

It seems to be working again after cleaning. I only made a couple small cuts, but had no issues.

Last night I went in and as soon as you hit the start button on the computer, before you hit the manual button to home it, it tosses up a z axis error.

I will be at the space in the morning I will fix it then if no one gets around to it before then

that seemed to do the trick i had no issues during class
Im designing a pc/cnc board enclosure for my own plasma and will most likely make another one for makeict as every few months we seem to have this issue

so if the plasma is glitching this is the current recommended fix

1 Like

also that error is often due to turning the torch on before the computer/machine!!! make sure to turn the computer on first, then the machine then the torch and the reverse for shutdown. if you leave the torch till last it will fire!


1 Like